Android Emulator Issue: The Android emulator process has unexpectedly stopped running.

All

Android Emulator Issue: The Android emulator process has unexpectedly stopped running.

While developing a fully native application (Hello World with C/C++ using Eclipse for Android (Full) Native Development), the error message, “The Android emulator process has unexpectedly stopped running.  The instance 480x800hdpi_NexusS_ARM7a_API10 is now stopped.” while attempting to run an Android emulator, through Eclipse.  The emulator never launches, after clicking the OK button.

Launching Native Emulator

I used the tutorial, “Setting up a development environment for Android App/Game Development on a Windows Platform” to setup my development environment.  I am using the following configuration, for my development:

    Java JRE 1.8.0 92
    Java JDK 1.8.0 92
    Android Studio 2.1.2
    Android SDK Manager, Revision 25.17
    Android NDK r11c
    Eclipse IDE for Java Developers Version Mars.2 Release (4.5.2)
    Eclipse Andmore Version 0.5.0.201605181018

As an alternative method, I can get the emulator working through the AVD manager; and I can get the fully native application running by dragging and dropping the *.apk file into the running emulator.  I can even see the print statements that I put into the application through LogCat.

Drag and drop the APK

Also, as a side note, the emulator runs normally if the developing app does not have any native code within it, ie only has Java in it.  (Hello World with Java using Eclipse for Android Development)

If you have a solution or any advice that I can try, please post it below.

Thanks for the help!!

If you enjoyed our material please contribute! Or, please check out our affiliation with Amazon, and their current deals.

Please, keep your comments family friendly and respectful of each other and the author.